SSL / Server Identify Errors with Mail Servers
Incident Report for Sentree
Resolved
This incident has been resolved.
Posted Aug 31, 2020 - 16:19 GMT-04:00
Update
We are continuing to monitor for any further issues.
Posted Aug 31, 2020 - 16:18 GMT-04:00
Monitoring
The SSL errors have been resolved and everything should be working properly. If you used the workaround, you can continue to leave the new hostname as it will continue to work as well. If you have any troubles, please reach out to us.
Posted Aug 31, 2020 - 13:39 GMT-04:00
Update
We are waiting for the email server provider to update the SSL certificate to fix this problem. This may not be resolved until Monday, but we are pushing for a quicker resolution.

In the meantime, you can access webmail at https://mail.b.hostedemail.com/ or update your email software and set the incoming and outgoing server to: mail.b.hostedemail.com
Posted Aug 28, 2020 - 22:19 GMT-04:00
Update
As a workaround, you can access webmail at https://mail.b.hostedemail.com/ or update your email client and set the incoming and outgoing server to: mail.b.hostedemail.com
Posted Aug 28, 2020 - 21:25 GMT-04:00
Identified
Customers are receiving an error when accessing webmail or from their email client about a failed SSL or Server Identity validation. We have identified the problem and are working to resolve it as quickly as possible.
Posted Aug 28, 2020 - 21:18 GMT-04:00
This incident affected: Email Hosting.