Delays on incoming email

Incident Report for Sentree

Resolved

All previous mail should have now been received. If you have any problems feel free to reach out to us at support@sentree.io or live chat at sentree.io.
Posted Jun 14, 2026 - 10:17 GMT-04:00

Monitoring

New emails are no longer delayed and older emails are coming in.
Posted Jun 14, 2026 - 10:03 GMT-04:00

Investigating

We are investigating reports of delayed incoming emails.
Posted Jun 14, 2026 - 09:09 GMT-04:00
This incident affected: Email Hosting.