Webmail Degraded Performance
Incident Report for Sentree
Resolved
The issues we were experiencing with delayed incoming mail and webmail performance are now resolved.
Posted 16 days ago. Feb 08, 2018 - 18:58 GMT-04:00
Update
Services on are beginning to return to normal levels and webmail performance has stabilized. Please note that inbound mail has been delayed during this incident, however outbound mail was not impacted.
Posted 17 days ago. Feb 08, 2018 - 17:19 GMT-04:00
Identified
Our operations team is investigating webmail performance issues at this time. Users may experience degraded performance sending and receiving mail as well as when visiting webmail.
Posted 17 days ago. Feb 08, 2018 - 16:35 GMT-04:00